Склеротичка по циске

Ничего умного, просто, чтобы у гугла не спрашивать.

Настройки терминала

Чтобы избежать мороки с автоматическим разбиением вывода на страницы

terminal length 0
terminal width 0

"Спасение утопающих"

Если есть шансы потерять раутер при внесении изменений (правка маршрутов, ACL и т.п.)

reload in 5

Если раутер всё еще доступен

reload cancel

Авторизация в консоли

При настройке свежей циски, иногда можно снести авторизацию в сериальной консоли и получить что-то типа такого:

Press RETURN to get started.
 
 
 
 
 
% Password expiration warning.
-----------------------------------------------------------------------
 
Cisco Configuration Professional (Cisco CP) is installed on this device 
and it provides the default username "cisco" for  one-time use. If you have 
already used the username "cisco" to login to the router and your IOS image 
supports the "one-time" user option, then this username has already expired. 
You will not be able to login to the router with this username after you exit 
this session.
 
It is strongly suggested that you create a new username with a privilege level 
of 15 using the following command.
 
username <myuser> privilege 15 secret 0 <mypassword>
 
Replace <myuser> and <mypassword> with the username and password you 
want to use.
 
-----------------------------------------------------------------------
 
Cisco881k9-Loc1>

Обычно, такое происходит, если сказать

aaa new-model

Чтобы восстановить:

aaa authentication login console local
aaa authorization exec console local 
!
line con 0
 login authentication console
 no modem enable
!

tcpdump

ACL не должен быть пустым! Иначе в дебаг будет лететь весь трафик, и при удалённой работе можно «потерять» терминал.
conf t
ip access-list extended 199
  1000 permit ip host 10.0.0.111 any
  1100 permit ip any host 10.0.0.111
  exit
exit
terminal monitor
debug ip packet 199 detail

В результате будем получать что-то типа такого:

*Nov 30 04:38:58.970: IP: s=10.0.0.111 (Vlan2), d=10.0.0.255, len 202, access denied
*Nov 30 04:38:58.970:     UDP src=138, dst=138
*Nov 30 04:38:59.722: IP: s=10.0.0.111 (Vlan2), d=10.0.0.255, len 78, access denied
*Nov 30 04:38:59.722:     UDP src=137, dst=137

резервный канал через ip sla

conf t
! что и как проверяем
ip sla 1
 icmp-echo 1.1.1.1 source-interface FastEthernet0
 timeout 100
 threshold 2
 frequency 3
 exit
! когда начнём проверку и когда закончим
ip sla schedule 1 life forever start-time now
! говорим, что надо отслеживать
track 123 rtr 1 reachability
! говорим, что если летит пинг на 1.1.1.1, его надо отправить через указанный интерфейс
! 
access-list 101 permit icmp any host 1.1.1.1 echo
route-map netcheck permit 10
 match ip address 101
 set interface FastEthernet0
 exit
! говорим, что это только для локального трафика (не для транзита)
ip local policy route-map netcheck
! задаём основной раут, указываем, что его надо чекать
ip route 0.0.0.0 0.0.0.0 1.1.1.1 track 123
! задаём раут с высокой метрикой
ip route 0.0.0.0 0.0.0.0 2.2.2.2 254

Пруф-линк

Добавить VLAN

с1812# vlan database
с1812(vlan)# vlan 5 name DCT 
VLAN 5 added:
    Name: DCT
с1812(vlan)#show
  VLAN ISL Id: 1
    Name: default
    Media Type: Ethernet
    VLAN 802.10 Id: 100001
    State: Operational
    MTU: 1500
    Translational Bridged VLAN: 1002
    Translational Bridged VLAN: 1003

  VLAN ISL Id: 2
    Name: Test2
    Media Type: Ethernet
    VLAN 802.10 Id: 100002
    State: Operational
    MTU: 1500

  VLAN ISL Id: 5
    Name: DCT
    Media Type: Ethernet
    VLAN 802.10 Id: 100005
    State: Operational
    MTU: 1500

с1812(vlan)#exit

net/склеротичка_по_циске.txt · Последние изменения: 2019-08-23 17:02 — Andrew A. Sabitov