Поиск пакетов, установленных из оверлеев

Иногда возникает необходимость удалить оверлей, но есть сомнение, в том, что пакеты из него не используются в системе. Если в системе стоит eix, можно использовать такой однострочник:

xxx ~ % eix --nocolor | egrep '^\[I\]|Installed versions' | grep -A1 '\[I\] .* \[.\]' ; eix --nocolor | tail -n 4 
[I] dev-python/pyexcelerator [2]
     Installed versions:  0.6.4.1(21:46:45 06.09.2012)(-examples)
--
[I] net-im/qutim-l10n [1]
     Installed versions:  0.3.0(13:13:48 06.09.2012)(linguas_ru -linguas_bg -linguas_cs -linguas_de -linguas_uk)
--
[I] x11-plugins/qutim-plugins [1]
     Installed versions:  0.3.0-r2(13:13:31 06.09.2012)(antispam aspeller bearermanager birthdayreminder clconf dbus dbusnotify floaties highlighter histman kineticpopups massmessaging multimediabackend scriptapi sdl unreadmessageskeeper urlpreview -adiumwebview -aescrypto -antiboss -awn -blogimprover -debug -emoedit -hunspeller -indicator -kde -nowplaying -phonon -qmlchat -weather -yandexnarod)
[I] x11-plugins/qutim-protocols [1]
     Installed versions:  0.3.0-r1(13:12:42 06.09.2012)(icq jabber -astral -debug -irc -libpurple -mrim -vkontakte)
 
[1] "qutim" /var/lib/layman/qutim
[2] "sunrise" /var/lib/layman/sunrise
 
Нашёл 16541 совпадений.

sys/поиск_установленных_пакетов_из_оверлеев.txt · Последние изменения: 2013-03-21 23:15 — Andrew A. Sabitov